Bookshelf Editor 1.1 User Manual

Author: Stephen Varnado
Version: 1.0
Date: November 3, 2013
# Table of Contents

1 Introducing Bookshelf Editor ................................. 4  
  1.1 About Bookshelf Editor .............................. 4  
  1.2 System requirements .............................. 4  
  1.3 How to use this manual .......................... 4  
  1.4 Copyright and contact information ......... 5  
2 Downloading and installing Bookshelf Editor ............ 5  
  2.1 Downloading Bookshelf Editor ................. 5  
  2.2 Installing Bookshelf Editor ...................... 6  
  2.3 Opening Bookshelf Editor ....................... 8  
3 Bookshelf Editor overview ................................ 10  
  3.1 User interface ...................................... 10  
  3.2 Menu bar .......................................... 11  
  3.2.1 File menu ...................................... 11  
  3.2.2 View menu ...................................... 12  
  3.2.3 Bookshelf menu ................................ 12  
  3.2.4 Object menu .................................... 13  
  3.2.5 Help menu ..................................... 13  
  3.3 Toolbar ............................................ 14  
  3.3.1 Bookshelf Title ................................ 15  
  3.3.2 Design Properties ........................... 16  
  3.3.3 Shelf Properties .............................. 16  
  3.3.4 Book Properties ............................... 17  
  3.3.5 ML Viewer ...................................... 18  
  3.3.6 Object Link .................................... 19  
  3.3.7 Object Palette ................................ 19  
  3.4 Display window ................................... 20  
4 Getting started in Bookshelf Editor .................. 20  
  4.1 Creating a new bookshelf file .................. 20  
  4.2 Adding a title to a bookshelf file .......... 21  
  4.3 Saving a bookshelf file .......................... 22  
  4.4 Opening an existing bookshelf file ........ 23  
  4.5 Viewing design properties .................... 25  
  4.5.1 Viewing bookshelf construction .......... 25  
  4.5.2 Viewing bookshelf background .......... 26  
  4.5.3 Viewing bookshelf statistics .......... 27  
  4.6 Exiting a bookshelf file ....................... 28  
  4.7 Deleting a bookshelf file ...................... 28  
5 Working with shelves ................................. 29  
  5.1 Adding a shelf ................................... 30  
  5.2 Modifying shelf width .......................... 31  
  5.3 Modifying shelf alignment .................... 33
Preface

Bookshelf Editor is a software application you can use to create and organize a visual library of URL links known as a bookshelf. This manual contains everything you need to know in order to install, use, and troubleshoot Bookshelf Editor.

1 Introducing Bookshelf Editor

1.1 About Bookshelf Editor

Bookshelf Editor is a software application used to create and organize a visual library of URL links known as a bookshelf. The links in a bookshelf can be graphically organized just like books on actual shelves. Each book contains a URL to a web page or local HTML file.

After you download and install the application on your computer, you will create and modify bookshelves in the user interface. Once you have created a bookshelf, export it to an HTML, XML, or XSL file and it is ready to be used.

You might want to use Bookshelf Editor to organize links for items such as:

- Cooking recipes
- News articles
- Online coursework
- Work-related resources

Below is an example of a bookshelf designed using Bookshelf Editor. It shows a collection of websites about various outdoor activities. It was exported to HTML and then opened in a browser.

Example of an HTML version of a bookshelf

1.2 System requirements

Bookshelf Editor is designed to run in a Windows environment.

System requirements:

- Microsoft Windows 95 or higher.
- 2 MB hard drive space.
- Internet access.
- A web browser such as Internet Explorer, Chrome, or Firefox.

1.3 How to use this manual

This manual contains everything you need to know in order to install, use, and troubleshoot Bookshelf Editor. Each section, or 'topic,' contains step-by-step instructions on how to complete key tasks. The manual is organized into topics and sub-topics, and you can navigate this content in a number of ways.

Below are brief descriptions of the features of this manual.

Features of this manual
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table of contents</td>
<td>Outlines the structure and content of the manual. Click a link to jump directly to that topic.</td>
</tr>
<tr>
<td>Navigation arrows</td>
<td>Left and right arrows are positioned at the top right of every page. Click them to move forward or backward through the topics.</td>
</tr>
<tr>
<td>Navigation path</td>
<td>A series of links located to the left of the navigation arrows. This shows your current position and the parent topics of the topic you are viewing.</td>
</tr>
<tr>
<td>Notes</td>
<td>Located at the bottom of a topic when necessary. Notes contain additional information and alternative methods to complete certain tasks.</td>
</tr>
<tr>
<td>Glossary</td>
<td>The second-to-last section of this manual. The glossary contains definitions of key terms and concepts.</td>
</tr>
<tr>
<td>Index</td>
<td>The last section of this manual. The index identifies exactly where key terms and concepts are located in the text. Click a number to jump directly to that page.</td>
</tr>
</tbody>
</table>

1.4 Copyright and contact information

Bookshelf Editor 1.1 copyright WatAGE Inc.


Bookshelf Editor uses Independent JPEG Group's JPEG Library Software (CJpeg.exe), Copyright 1994-1996.

This user manual was authored by Linda Longenecker (llongenecker@bresnan.net) and Stephen Varnado (svarnado@gmail.com), 2013.

2 Downloading and installing Bookshelf Editor

2.1 Downloading Bookshelf Editor

To download Bookshelf Editor:

1. Open a browser and navigate to the Course downloads page for the Online-learning.com Professional Technical Writing course.
2. Click BookshelfEditor11.exe.
   
   The Opening BookshelfEditor11.exe window will open.
3. Click Save File.
4. Click the All files have finished downloading link in the "Downloads Complete" window.
2.2 Installing Bookshelf Editor

To install Bookshelf Editor:

1. Double-click **BookshelfEditor11.exe** at the top of the download Library.

2. Click **Next** in the Bookshelf Editor 1.1 Install window.
3. Accept the software Terms and Conditions and click Next.
4. Click OK in the Bookshelf Editor 1.1 Install window.

Bookshelf Editor will open automatically.
2.3 Opening Bookshelf Editor

To open Bookshelf Editor:

1. Click the **Bookshelf Editor 1.1** icon on your desktop.

2. Click **Agree** in the Student Bookshelf Editor window.
Bookshelf Editor is ready for use with an empty shelf in the display window.
3 Bookshelf Editor overview

3.1 User interface
The user interface is where you will create, modify, and export your bookshelves.
It has three components:

- Menu bar
- Toolbar
- Display window
3.2 Menu bar

The Menu bar is shown below:

The Menu bar contains five menus you can use to perform all major tasks in Bookshelf Editor:

- File menu
- View menu
- Bookshelf menu
- Object menu
- Help menu

3.2.1 File menu

The File menu is shown below:
The File menu

The File menu contains the following options for working with bookshelf files:

<table>
<thead>
<tr>
<th>File menu options</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Bookshelf</td>
<td>Create a new bookshelf.</td>
</tr>
<tr>
<td>Open</td>
<td>Open an existing bookshelf.</td>
</tr>
<tr>
<td>Save</td>
<td>Save the bookshelf that is currently open.</td>
</tr>
<tr>
<td>Save As</td>
<td>Save the current bookshelf for the first time or under a new name or file location.</td>
</tr>
<tr>
<td>Export Bookshelf</td>
<td>Export the current bookshelf as an HTML, XML, or XSL file.</td>
</tr>
<tr>
<td>Exit</td>
<td>Exit Bookshelf Editor.</td>
</tr>
</tbody>
</table>

3.2.2 View menu

The View menu is shown below:

The View menu

The View menu contains the option to view the Toolbar. This option is always selected by default.

3.2.3 Bookshelf menu

The Bookshelf menu is shown below:

The Bookshelf menu
The Bookshelf menu contains the following options for working with bookshelves:

**Bookshelf menu options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design Properties</td>
<td>Modify bookshelf name and appearance: construction, background, title, file statistics.</td>
</tr>
<tr>
<td>Shelf Properties</td>
<td>Modify the width or justification of the selected shelf.</td>
</tr>
<tr>
<td>Add New Shelf</td>
<td>Add a new shelf beneath the selected shelf.</td>
</tr>
<tr>
<td>Delete Selected Shelf</td>
<td>Delete the selected shelf.</td>
</tr>
<tr>
<td>ML Viewer</td>
<td>View the XML or HTML markup language for a bookshelf.</td>
</tr>
</tbody>
</table>

**Note:** In this application *shelf* refers to an individual row of books. *Bookshelf* refers to all of the shelves as a whole.

### 3.2.4 Object menu

The Object menu is shown below:

![Image](image.png)

**The Object menu**

The Object menu contains the following options for working with objects:

**Object menu options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert</td>
<td>Insert a default book, a wide book, or a space in the next available spot to the right on the selected shelf.</td>
</tr>
<tr>
<td>Book Properties</td>
<td>Modify the width, color, title, or URL of the selected book. Modify the width of the selected space.</td>
</tr>
<tr>
<td>Move Left</td>
<td>Move the selected book or space one position to the left.</td>
</tr>
<tr>
<td>Move Right</td>
<td>Move the selected book or space one position to the right.</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete the selected book or space.</td>
</tr>
</tbody>
</table>

**Note:** In this application *object* refers to a book or a space.

### 3.2.5 Help menu

The Help menu is shown below:
The Help menu

When you click About Bookshelf Editor, the following information is displayed:

3.3 Toolbar

The Toolbar is shown below:
The Toolbar contains seven sections you can use to perform common tasks in Bookshelf Editor:

- Bookshelf Title
- Design Properties
- Shelf Properties
- Book Properties
- ML Viewer
- Object Link
- Object Palette

### 3.3.1 Bookshelf Title
The Bookshelf Title section is shown below:
The Bookshelf Title section displays the following:

<table>
<thead>
<tr>
<th>Bookshelf Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
</tr>
<tr>
<td>Shelves, Number</td>
</tr>
<tr>
<td>Shelves, Current</td>
</tr>
</tbody>
</table>

### 3.3.2 Design Properties

The Design Properties button is shown below:

If you click Design Properties the window on the right opens:

The Design Properties window allows you to view and modify the following:

<table>
<thead>
<tr>
<th>Design Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Construction</td>
</tr>
<tr>
<td>Bookshelf Title</td>
</tr>
<tr>
<td>Background</td>
</tr>
<tr>
<td>File Statistics</td>
</tr>
</tbody>
</table>

### 3.3.3 Shelf Properties
The Shelf Properties button is shown below:

If you click Shelf Properties the window on the right opens:

The Shelf Properties window allows you to view and modify Shelf Width and Justification.

### 3.3.4 Book Properties

The Book Properties button is shown below:

If you click Book Properties the window on the right opens:

The Object Properties window allows you to view and modify the following:

**Object Properties**
<table>
<thead>
<tr>
<th>Style</th>
<th>The width of the selected book: Normal Width or 120% Width.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Colour</td>
<td>The color the selected book: Gray-Green, Blue-Gray, Mauve, or Sky Blue.</td>
</tr>
<tr>
<td>Title</td>
<td>The title of the selected book.</td>
</tr>
<tr>
<td>URL Link</td>
<td>The URL or directory path of the selected book.</td>
</tr>
<tr>
<td>Object Information</td>
<td>The Object Width and Binding Width of the selected book.</td>
</tr>
</tbody>
</table>

### 3.3.5 ML Viewer

The ML Viewer section is shown below:

If you click View XML the window on the right opens, showing the XML code for the current bookshelf:

If you click View HTML the window on the right opens, showing the HTML code for the current bookshelf:
3.3.6 Object Link

The Object Link section is shown below:

The Object Link displays the URL or directory path of the selected book. It is the book's topic or subject matter, similar to the contents of an actual book.

Note: The Object Link section is only a display feature. To enter or modify the URL or directory path of a book, use the Object Properties window.

3.3.7 Object Palette

The Object Palette section is shown below:

The Object Palette contains the objects that you can add to a shelf: a default book, a wide book, and a space. This is similar to objects you would place on an actual bookshelf. When you click one of these objects it is added to the next available spot to the right on the selected shelf.
3.4 Display window

The display window shows the bookshelf you are editing and all the objects it contains.

**Note:** The red arrow indicates the shelf that is currently selected.

4 Getting started in Bookshelf Editor

4.1 Creating a new bookshelf file

To create a new bookshelf file:

1. From the **Menu**, click **File > New Bookshelf**.
The New Bookshelf Confirmation window will open.

2. Click **Yes**.

A new bookshelf will open.

**Note:** The current bookshelf file will not be erased as indicated in the New Bookshelf Confirmation window. The bookshelf file will be closed and any changes that have not been saved will be lost.

**Note:** You can also press **Ctrl+N** to create a new bookshelf file.

### 4.2 Adding a title to a bookshelf file

To add a title to a bookshelf file:

1. From the **Menu**, click **Bookshelf > Design Properties**.
2. Type the title in the **Bookshelf Title** field of the Design Properties window.

3. Click **OK**.

**Note:** You can also add a title to a bookshelf file from the Title section at the top of the Toolbar.

### 4.3 Saving a bookshelf file

To save a bookshelf for the first time, or under a new name:

1. From the **Menu**, click **File > Save As**.

**The Save As window will open to the bookshelfeditor folder.**

2. Type the name in the **File name** field and click **Save**.
4.4 Opening an existing bookshelf file

To open an existing bookshelf file:

1. From the Menu, click File > Open.

2. Double-click the file you wish to open.
The bookshelf will open.
4.5 Viewing design properties

4.5.1 Viewing bookshelf construction

To view the bookshelf construction material:

1. From the **Menu**, click **Bookshelf > Design Properties**.

2. View the Construction material in the upper left corner of the Design Properties window.

**Note:** You can also press **Ctrl+O** to open an existing file.
4.5.2 Viewing bookshelf background

To view the background material of your bookshelf:

1. From the **Menu**, click **Bookshelf > Design Properties**.

2. View the Background material in the lower left corner of the Design Properties window.
4.5.3 Viewing bookshelf statistics

To view the file statistics of your bookshelf:

1. From the **Menu**, click **Bookshelf > Design Properties**.

2. View the File Statistics in the lower right corner of the Design Properties window.
4.6 Exiting a bookshelf file

To exit a bookshelf file:

1. Save any changes you wish to keep to the bookshelf file.
2. From the Menu, click File > Exit.

*Note: The bookshelf file will close.*

*Note: Save any changes you wish to keep before exiting the bookshelf file or they will be lost.*

4.7 Deleting a bookshelf file

To delete a bookshelf file:

1. Open Windows explorer and navigate to Bookshelf Editor 1.1 > bookshelfeditor.
2. Right-click the file you wish to delete and click **Delete**.

The *bookshelf* file will be deleted.

5 **Working with shelves**
5.1 Adding a shelf

To add a shelf to the bookshelf:

1. From the Menu, click Bookshelf > Add New Shelf.

The Shelf Properties window will open.

2. Click OK.

The new shelf will be added below the existing shelf.
Note: The red arrow next to a shelf indicates the shelf that you have chosen or are working with.

Note: The maximum number of shelves you can add to a bookshelf is three (3).

5.2 Modifying shelf width

To modify the width of a shelf:

1. Click the shelf that you want to change the width on.
2. From the Menu, click Bookshelf > Shelf Properties.

The Shelf Properties window will open.
3. Using the dropdown menu in the **Shelf Width** box, choose the width you want the shelf to be.

4. Click **OK**.

The bookshelf displays two shelves, each with a different width.

**Note:** The red arrow next to a shelf indicates the shelf that you have chosen or are working with.

**Tip:** You can also quickly access **Shelf Properties** from the Toolbar.

### 5.3 Modifying shelf alignment
To modify the shelf alignment:

1. Click the shelf that you want to change the alignment on.

2. From the **Menu**, click **Bookshelf > Shelf Properties**.

*The Shelf Properties window will open.*
3. In the **Justification** box, choose the justification that you want the shelf to be.

4. Click **OK**.

The bookshelf will display the new alignment of the shelf that was changed.

**Note:** The red arrow next to a shelf indicates the shelf that you have chosen or are working with.
5.4 Deleting a shelf

To delete an existing shelf from the bookshelf:

1. Click the shelf that you want to delete.

2. From the Menu, click **Bookshelf > Delete Selected Shelf**.

Note: The red arrow next to a shelf indicates the shelf that you have chosen or are working with.
6 Working with books

6.1 Adding a book

To add a book to a bookshelf:

1. Click the shelf that you want to add a book to.

2. From the **Menu**, click **Object > Insert > Default Book** or **Wide Book**.

**Caution:** If you delete a shelf that contains books, they will also be deleted.
The book will be added to the shelf.

**Note:** The red arrow next to a shelf indicates the shelf that you have chosen or are working with.

**Tip:** You can quickly add a book from the Object Palette on the Toolbar by clicking on either Object. You can also add a book by pressing Ctrl+O to add a default book or Ctrl+W to add a wide book.

**Note:** In this application, **Objects** refer to a book or space. You will learn about spaces in Section 7.
6.2 Adding a title to a book

To add a title to a book:

1. Click the book that you want to add a title to.

2. From the Menu, click Object > Book Properties.

3. In the Title box, type the title of the book.
4. Click **OK**.  
The book will now display the title.

### 6.3 Modifying book color

To change the color of a book:

1. Click the book that you want to change the color on.
2. From the **Menu**, click **Object > Book Properties**.

The **Object Properties** box will open.
3. In the **Colour** box, click the color that you want the book to be.

   *The default color is Gray-Green.*

4. Click **OK**.

   *The book will display in the bookshelf with the new color.*
Tip: You can quickly access **Book Properties** from the Toolbar or by pressing **Ctrl+J**.

### 6.4 Adding a local URL link to a book

To add a local URL link to a book:

1. Click the book that you want to add a URL Link to.

2. From the **Menu**, click **Object > Book Properties**.
3. In the **URL Link** box, click **Browse Disk**.

4. Using *Windows Explorer*, navigate to the document that you want to link to.
5. Click the document.

The path to the document will show in the URL Link box.

6. Click **OK**.

The URL link for that book will show in the Object Link field.

---

**Tip:** You can quickly access **Book Properties** from the Toolbar or by pressing **Ctrl+J**.

### 6.5 Adding a web URL link to a book

To add a web URL link to a book:

1. Open a web browser (e.g. Internet Explorer, Firefox, or Chrome).
2. Navigate to the web page that you want to link the book to.
3. Copy the URL for the web page.
4. In **Bookshelf Editor**, click the book that you want to link to.
5. From the **Menu**, click **Object > Book Properties**.
6. In the URL Link box, **Paste** the URL.

7. Click **OK**.

*The URL link for that book will show in the Object Link field*
Tip: You can quickly access the Book Properties from the Toolbar or by pressing Ctrl+J.

6.6 Moving a book left or right

To move a book left or right:

1. Click the book that you want to move.

2. From the Menu, click Object > Move Left or Move Right.

In this example, the book titled Zip Line has moved to the left of the space.
6.7 Viewing book properties

To view book properties:

1. Click the book whose properties you want to view.

2. From the **Menu**, click **Objects > Book Properties**.

The **Book Properties** window will open where you can view the name of the book and the URL link associated with the book.
6.8 Deleting a book

To delete a book:

1. Click the book you want to delete.

2. From the Menu, click Object > Delete.
7 Working with spaces

7.1 Adding a space

To add a space to a bookshelf:

1. Click the shelf that you want to add a space to.

2. From the Menu, click Object > Insert > Space.
A space will be added to the right of all books. If this is not the desired location that you want the space to be you will need to move the space to the left.

**Note:** The red arrow next to a shelf indicates the shelf that you have chosen or are working with.

**Note:** You can also add a space by clicking the space object located in the **Object Palette** on the Toolbar, or by pressing **Ctrl+E**.

**Tip:** The use of spaces can help you organize your bookshelf into different categories.
7.2 Moving a space

To move a space left or right:

1. Click the space that you want to move.

2. From the **Menu**, click **Object > Move Left** or **Move Right**.

*The space has been moved one space to the left.*
Note: You can also move a space by clicking the space and pressing Ctrl+Right Arrow or Ctrl +Left Arrow.

Note: Spaces can only be moved if there is a book or space to the left or right of the space you are moving.

7.3 Changing the space width

To change the width of a space.

1. Click the space that you want to change the width on.
2. From the **Menu**, click **Object > Book Properties**.

*The Space Properties window will open.*
3. Click the **Slider** in the **Space Tracker Bar** and slide it to the right until you reach the desired width.

4. Click **OK**.

   *The space will be shown with the wider width.*

---

**Note:** You can also change the width of a space by clicking **Book Properties** on the Toolbar and following step 3 above, or by pressing **Ctrl+J**.

### 7.4 Deleting a space

To delete a space:

1. Click the space that you want to delete.
2. From the **Menu**, click **Object > Delete**.

The space will no longer show on the bookshelf.
8 Exporting bookshelves

8.1 Exporting to HTML

To export to HTML:

1. From the Menu, click File > Export Bookshelf.
The Export Bookshelf window will open with the HTML Document and JPEG Image File boxes checked.

Note the file path in the Directory for Export field, as you will need this when you open the bookshelf in a browser or editor.
2. Click **Export Now**. If the export was successful, The Export Successful window will open.

An HTML document (*.html); Hypertext Markup Language (HTML) is the language used by most web pages. Bookshelf files in this format may be opened and viewed in a web browser. This format is used by those who want to access files located on the web or their local computer.

**Caution:** You must export both the **HTML Document** and JPEG Image File in order to view the files in a web browser.

### 8.2 Exporting to XML

To export to XML:

1. From the **Menu**, click **File > Export Bookshelf**.
2. **Uncheck** the HTML Document and JPEG Image File boxes.
3. Check the XML Document box.

4. **Click Export Now.**
   
   *If the export was successful, The Export Successful window will open.*
An XML (*.xml): Extensible Markup Language (XML) is a simple and flexible document description language based on SGML. Bookshelf files in this format may be opened and edited in any XML Editor.

### 8.3 Exporting to XSL

To export to XSL:

1. From the **Menu**, click **File > Export Bookshelf**.

2. **Uncheck** the **HTML Document** and **JPEG Image File** boxes.

3. Check the **XSL Document** box.
4. Click **Export Now**.

An XSL Document (*.xsl): XML Style Language (XSL) is the formatting language that allows XML documents to be displayed on web browsers or printed. Bookshelf files in this format may be opened and edited in any XML/XSL editor.

**Tip:** You can export all files at the same time by checking all boxes in the Export Bookshelf window.

9 Opening and using bookshelves

9.1 Opening a bookshelf in a web browser

To open a bookshelf in a web browser:

1. Open a web browser.
2. On the browser's menu bar, click **File > Open** or **File > Open File** depending on the browser you are using.
Firefox Browser

3. Browse to the address of the exported file.

You can also just type the address into the box.

4. Click OK.

The bookshelf will be viewable in the web browser.
9.2 Using bookshelf links

To use a bookshelf link:

1. Open a bookshelf in a browser.

2. Click a book.

   *The web page or document that is associated with the book will open.*
9.3 Opening a bookshelf in XML editor

To open a bookshelf in a XML editor:

1. Open the XML Editor.
2. From the Menu, click File > Open.

3. Find the XML or XSL files using the path from the Export Document window.
4. Click the XML or XSL file that you want to open.

The files will open in the Editor window.
Bookshelf Editor 1.1 is very useful in organizing links to web pages and HTML documents for easy access. As you design and use your bookshelf, you may encounter some limitations or common bugs. The list below identifies the most common issues that users run into:

1. Book titles will render correctly when the shelf width is 100% and aligned to the left. If you have problems viewing titles, check the shelf width and alignment.
2. Each bookshelf can contain up to three shelves.
3. When deleting shelves that contains a book or books, they will also be deleted.
4. Using shorter titles for books will allow the name to be fully displayed.
5. If you wish to move a book from one shelf to another you will need to delete it and then add it to the new shelf.
6. Books or spaces can be moved one space to the left or right at one time.
7. Use the Space Trackbar to define the width of a space.
8. Save your bookshelf inside the Bookshelf Editor folder in order for it to display correctly.
9. The current version of the Bookshelf Editor includes redwood construction and scrapbook background.

11 Technical Support

For technical support, contact:

- Linda Longenecker at ilongenecker@bresnan.net.
- Stephen Varnado at svarnado@gmail.com.
**Glossary**

**Book**

A virtual book that contains a link to an HTML document or web page.

**Book properties**

Provides information about a book, including the style, color, title, and URL link.

**Bookshelf**

A virtual bookshelf that contains shelves and holds books. Each bookshelf may contain up to three shelves.

**Bookshelf file**

A bookshelf file, or “bookshelf,” is a single document that contains a collection of URL links to web pages or computer file locations.

**Design properties**

The Design Properties contains options for building a bookshelf including the construction, background, bookshelf title, and file statistics information.

**Directory path**

A directory path is the route taken through a computer system to locate a specific file.

**Display window**

The display window is a graphic depiction of a bookshelf and all the objects it contains.

**Export**

To convert a bookshelf file into another format such as HTML so that it can be opened and used in a different application such as a web browser.

**HTML**

HyperText Markup Language (HTML) is the primary language used to create web pages and other information that can be displayed in a browser.

**Justification**

Justification is the visual alignment of a shelf to the right or to the left.

**Link**

A link, or “hyperlink,” is a connection in a book to a specific web page or computer file.

**Menu bar**

The menu bar is a row of drop-down text menus that allow you to perform all major tasks in Bookshelf Editor.

**ML Viewer**

The ML View contains View XML and View HTML buttons. When you click on a button you are able to see the XML Code for bookshelf.

**Object**

In this application, Object refers to a book or a space. When you click on Object in the Menu bar you can insert books or spaces, view book or space properties, move books or spaces, or delete books or spaces.

**Object link**

The Object Link is viewable on the Bookshelf Editor's Toolbar and will show the URL that is associated with a book.

**Object palette**
The Object Palette is viewable on the Bookshelf Editor's Toolbar and contains objects for the default book, wide book, and space. When you click on any of these objects, it will be added to the active shelf.

Shelf

A shelf is the part of the bookshelf that holds the books.

Shelf properties

The Shelf Properties window allows you to choose shelf width and shelf justification.

Toolbar

The Toolbar is a graphic display of selectable “buttons” that allow you to perform common tasks in Bookshelf Editor.

URL

A uniform resource locator (URL) is a web address that refers to a specific location on the Internet.

XML

Extensible Markup Language (XML) is a document description language commonly used to create web documents.

XSL

XML Style Language (XSL) is the formatting language that allows XML documents to be displayed in web browsers or printed.
Index

Book, add,37
Book, add title,39
Book, change color,40
Book, delete,49
Book, move,47
Book, view properties,48
Bookshelf Editor, about,4
Bookshelf Editor, downloading,5
Bookshelf Editor, installing,6
Bookshelf Editor, opening,8
Bookshelf file, adding title,21
Bookshelf file, background,26
Bookshelf file, construction,25
Bookshelf file, creating new,20
Bookshelf file, deleting,28
Bookshelf file, exiting,28
Bookshelf file, opening existing,23
Bookshelf file, saving,22
Bookshelf file, statistics,27
Bookshelf menu,13
Bookshelf, open in Web browser,62
Bookshelf, open in XML editor,65
Bookshelf, Using in Web browser,64
Design Properties,16
Display window,20
Export, to HTML,57
Export, to XML,59
Export, to XSL,61
File menu,12
Help manual, using,4
Help menu,13
HTML Language,59
Menu bar,11
ML Viewer,18
Object menu,13
Object Properties, 17
Shelf Properties, 17
Shelf, add, 30
Shelf, delete, 36
Shelf, justification, 35
Shelf, modify alignment, 34
Shelf, modify width, 31
Space, add, 50
Space, change width, 53
Space, delete, 55
Space, move, 52
System requirements, 4
Technical Support, contacting, 68
Toolbar, 15
Toolbar, bookshelf title, 16
Toolbar, object link, 19
Toolbar, object palette, 19
Troubleshooting, 67
URL, add local link, 43
URL, add Web link, 45
User interface, 10
View menu, 12
XML Language, 61
XSL Language, 62